It is currently Mon, 30 Mar 2020 22:32:28 GMT



 
Author Message
 'floating point exception' when running top
Here's my situation...

I do a slackware 3.0 install, everything works well.  So far I've compiled
both 1.3.60, 1.3.66, and 1.3.67.  All aspects of the make, and install go
flawlessly.  After booting to the new kernel, 'top' will give a 'floating
point exception' as well as 'ps -u'.  These are the only commands that are
affected as far as I know.

I'm open to any suggestions anyone may have regarding this problem.

Also, if anyone is having problems installing ppp v2.2.0e, get the patch
from sunsite.unc.edu/pub/Linux/Incoming.  It works.

--
--

|Jeff Reese                 |Premier One Inc.
|jre...@jeff.com            |j...@premier.net
|www.premier.net/~jreese    |www.premier.net



 Fri, 14 Aug 1998 03:00:00 GMT   
 'floating point exception' when running top
On 26 Feb 1996 06:06:40 GMT, Jeff Reese <jre...@jezebel.oneill.net> wrote:

Compile and install procps-0.99.  This should solve your problem.

Later,
Ashok

--
Ashok Aiyar
Department of Oncology                ai...@ebv.oncology.wisc.edu
Univ. of Wisconsin-Madison                    tel: (608) 262-6697



 Fri, 14 Aug 1998 03:00:00 GMT   
 'floating point exception' when running top

: Compile and install procps-0.99.  This should solve your problem.

        where do i get procps-0.99?

        i looked on wcarchive and sunsite,
        but probably looked in the wrong
        directories...



 Sat, 15 Aug 1998 03:00:00 GMT   
 'floating point exception' when running top
: Here's my situation...
:
: I do a slackware 3.0 install, everything works well.  So far I've compiled
: both 1.3.60, 1.3.66, and 1.3.67.  All aspects of the make, and install go
: flawlessly.  After booting to the new kernel, 'top' will give a 'floating
: point exception' as well as 'ps -u'.  These are the only commands that are
: affected as far as I know.
:
: I'm open to any suggestions anyone may have regarding this problem.

        In kernels 1.3.53 and higher, top and ps -u are BROKEN! there's no way
around the problem, so what you'll need to do is upgrade your version of
procps to 0.99. It's available at tsx-11.mit.eu:/pub/linux/BETA/procps, or at
your neighbourhood SunSITE mirror.

                                                        BL.



 Sat, 15 Aug 1998 03:00:00 GMT   
 'floating point exception' when running top

As I understand it, Linus, Alan, et al changed the way the proc fs worked sometime in the 1.3.50's.  What you'll
have to do is get the procps-0.99 package from a sunsite mirror.  Try

        http://www.cc.gatech.edu/ftp/Linux/system/Status/ps/procps-0.99.tgz

There's also a procps-0.99a.tgz in the Incoming directory, not sure what's been fixed (or broken).

This should take care of the problem.
--
%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%
    Lee Burnside --SysAdmin-- TTU Dept. of Physics
            tl...@tomserver.phys.ttu.edu
      Physics Homepage: http://www.phys.ttu.edu/
       University Hoempage: http://www.ttu.edu/
%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%
   So long as men can breathe, or eyes can see,
   So long lives this, and this gives life to thee.
                --The Bard
   Inna Gadda Da Vida, Baby.
                --Iron Butterfly



 Tue, 18 Aug 1998 03:00:00 GMT   
 
   [ 5 post ] 

Similar Threads

1. floating point exception running top on cyrix p166 with linux 2.0.28

2. Post 2.0.29 FLoating Point Exception's

3. what's with the floating point exception with new kernels

4. floating point exception in TOP

5. top - gets floating point exception with Netatalk installed

6. Floating point exception when using TOP

7. top gives floating point exception

8. Top Floating Point Exception

9. Linux 1.3.54 + Top = Floating Point Exception


 
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by ST Software