It is currently Tue, 29 Jul 2014 21:59:23 GMT



 
Author Message
 PPP crash with 1.3.100 (ISDN?)

Hi friends,

I downloaded 1.3.100 and made a kernel on my pentium,  using config
option 486, because otherwise unknown compiler options of gcc 2.6.3 crashed
the make zImage. I want to use PPP on a teles.s16.3 ISDN-card. Thus I choose
PPP and ISDN and ISDN_PPP plus some compressing support. The
README-recommended setup of the isdn4linux-utils by
ftp.franken.de:/pub/Linux/isdn4linux (latest version) finally compiled after
changing the file sys-linux.c in isdn4k-utils-1.3.91/ipppd.2.2:
the route.h file now resides in linux/route.h instead of net/route.h.

However
the new kernel says while starting the daemons
 kernel: fcntl_setlk() called by process 53 with broken flock() emulation
 kernel: fcntl_setlk() called by process 56 with broken flock() emulation
 kernel: fcntl_setlk() called by process 55 with broken flock() emulation
 kernel: fcntl_setlk() called by process 57 with broken flock() emulation
 kernel: fcntl_setlk() called by process 71 with broken flock() emulation

and PPP doesn't work at all it says:
Sorry PPP not available on this System.

Can somebody help me ?

Jobst H. Koehne  ko...@rec06.desy.de



 Thu, 12 Nov 1998 03:00:00 GMT   
 PPP crash with 1.3.100 (ISDN?)

In <4o96t8$...@dscomsa.desy.de>, ko...@rec06.desy.de (Jobst Heinrich Koehne) writes:

I have no idea what the flock() means but I read that in order for those
messages to dissapear you'll have to recompile the kernel with GCC 2.7.2
I get several of those messages when I boot on Linux. I guess it would
apply to PPP as well.
I'm using the same version but haven't notice that yet since I have no
idea how to install PPP under Linux, I'm using OS/2 for Internet.

Does GCC 2.7.2 supports streamable classes and where can I get full
information on that compiler. I know nothing of GCC, so far I've used
only OS/2, dos and windoze commercial compilers.

P.S. I've always thought that flock had something to do with religion
or politic.
What is it doing in a C++ compiler's list of messages?

----------------------------------------------------------

Michel Catudal                      bb...@netonecom.net

Fier d'tre membre de Team OS/2 USA
Miembro orgulloso del Team OS/2 USA
Proud member of Team OS/2 USA

----------------------------------------------------------



 Fri, 13 Nov 1998 03:00:00 GMT   
 PPP crash with 1.3.100 (ISDN?)

Hi again!

You need to install libc 5.2.18 (from any of the standard linux
locations, e.g. ftp://sunsite.unc.edu/pub/Linux). Put the file
libc.so.5.2.18 into /lib (actually, just unpack the entire libc-5.2.18
distribution into /), and re-run "/sbin/ldconfig" as root. Then reboot.

--
Shankar Unni                                  shan...@chromatic.com
Chromatic Research                            (408) 752-9488



 Sat, 14 Nov 1998 03:00:00 GMT   
 
   [ 3 post ] 

Similar Threads

1. LINX 1.3.100, PPP and UUGETTY not cooperating

2. Kernel 1.3.100 - PPP not available?

3. ? about ppp and 1.3.100

4. Kernel 1.3.100 and lpd.

5. Upgd 1.2.13 -> 1.3.100

6. Problem with 1.3.100 kernel

7. Modules problem with 1.3.100

8. No more pppd on kernel 1.3.100

9. Installing Modules on linux kernel 1.3.100


 
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by ST Software