It is currently Tue, 07 Dec 2021 02:30:23 GMT



 
Author Message
 "at" command doesn't work after increasing ulimit, HELP Please!
Hello net people:

        We have increased our ulimit on our AT&T 3B2/300 70meg 2meg machine
with the following C program /bin/login.  The original /bin/login was moved
to /bin/login2:  The program works.

                #include <stdio.h>
                main(argc,argv)
                char **argv;
                {
                char *ptr;
                char *largs[3];
                char logname[64];
                largs[0] = "login";
                largs[1] = strncpy(logname,argv[1],64);
                largs[2] = NULL;
                ulimit(2,32768);
                execv("/bin/login2",largs);
                }

        Now, when I atempt to use "at", even with a simple {echo "burp"} I
recive the following error in my mail and the command does not execute:

                sh: Bad ulimit

                *************************************************
                Cron: The previous message is the standard output
                      and standard error of one of your cron commands.

        Also, when we increased our ulimit crypt began to give us a
"crypt: cannot generate key" error.  I don't know if this is related?
Does anyone out there have a solution?

                                Thank you,
   _______
   |     |                      James D. Corder
   |UNIX!|                      P.O. Box 27473
  ---------                     Columbus, Ohio 43227
   \~. .~/
   (  *  )                      ...cbatt!osupyr!Alix!corder
----| O |----
    \ v /
 --- \ / ---
      V                         Your comments may someday become part of a book!



 Thu, 17 Sep 1992 17:37:00 GMT   
 "at" command doesn't work after increasing ulimit, HELP Please!
In article <1...@osupyr.UUCP> j...@osupyr.UUCP (Jim D Corder) writes:

We had a similar problem with a 3B2-400 that we had.  Our ULIMIT was
set for 1 meg.  To get around this we used a shell script that set the
ULIMIT up before getty was called.  It looked like this:

   /etc/biggetty :

     ulimit 4096
     /etc/getty $1 $2

All that was needed was to make a change to /etc/inittab to call
biggetty with the parameters of the tty# and the baud rate.  This
script worked fine for us.  Now we have a NCR Tower 32 and a XP.  We
don't need it on these machines.

-Bob

--
 Robert A. Monio                              UUCP: ihnp4!meccts!nis!pnessutt
 Systems/Analyst - Technical Services         ATT: (612) 894-9494
 National Information Systems, Inc.
                      "These Proceedings are Closed!"



 Thu, 17 Sep 1992 23:26:00 GMT   
 "at" command doesn't work after increasing ulimit, HELP Please!
In article <1...@osupyr.UUCP> j...@osupyr.UUCP (Jim D Corder) writes:

This may be a red herring, since I think longs and ints on a 3B2 are the
same size, but the second arg to ulimit is supposed to be a long.
So the call to ulimit should read:

                ulimit(2,32768L);

--
Larry Campbell                                The Boston Software Works, Inc.
Internet: campb...@maynard.BSW.COM          120 Fulton Street, Boston MA 02109
uucp: {alliant,think,wjh12}!maynard!campbell        +1 617 367 6846



 Thu, 17 Sep 1992 12:09:00 GMT   
 "at" command doesn't work after increasing ulimit, HELP Please!
In article <1...@osupyr.UUCP>, j...@osupyr.UUCP (Jim D Corder) writes:

We use a very similar program at our site to increase the ulimit.
You must edit the file /etc/rc.d/cron and insert a line before the
invocation of cron to set a new ulimit.  Our file is as follows:

#       @(#)cron        1.1     /sccs/src/cmd/sadmin/etc/rc.d/s.cron
#       Start cron demon

ulimit 240000
/etc/cron

This will fix you problem.

--
Metro T. Sauper, Jr.                              Assessment Systems, Inc.
Director, Remote Systems Development              210 South Fourth Street
(215) 592-8900                 ..!asi!metro       Philadelphia, PA 19106



 Thu, 17 Sep 1992 19:43:00 GMT   
 
   [ 4 post ] 

Similar Threads

1. HELP: "volcheck" doesn't work

2. "Ping" doesn't work properly

3. "host" doesn't work

4. "Cabletronic 21xx" doesn't work

5. "newkey" doesn't work

6. "locate" doesn't work

7. "w" doesn't work


 
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by ST Software