It is currently Mon, 18 Nov 2019 22:37:29 GMT



 
Author Message
 ppp.linkup not executed
Hi together,

PPP works so far. But my /etc/ppp.linkup will not be executed after a
dial (the connection works, I'm posting this message over it):

$ ls /etc/ppp/ppp.linkup
2 -rw-r--r--  1 root  wheel  35 Feb  4 20:49 /etc/ppp/ppp.linkup

$ cat /etc/ppp/ppp.linkup
MYADDR:
!bg echo "online" > /tmp/test

$ ppp -ddial tdsl
Working in ddial mode
Using interface: tun0

$ cat /tmp/test
$

So it is obvious, that ppp.linkup was not executed after a dial. BTW a
ppp.linkup as follow does not work either:

$ cat /etc/ppp/ppp.linkup
MYADDR:
! sh "/bin/rm /tmp/test"

$ cat /etc/ppp/ppp.linkup
default:
!bg echo "online" > /tmp/test

What's the problem? I really don't see any fault...

Please help.
reiner



 Sun, 24 Jul 2005 04:59:09 GMT   
 ppp.linkup not executed
On Tue, 04 Feb 2003 21:59:09 +0100, Reiner Griess <mynewn...@gmx.net>
said the following:

I believe you need to put a space before '!'.  I just tried this here
and it worked:

MYADDR:
 !bg sh -c /bin/echo online > /tmp/test

My problem is that when I run ppp -ddial <label> the dest_addr of
127.2.2.2 gets put as default gateway and then the thing hangs (modem
won't dial).  I need to kill the ppp process and remove that route
(default gateway as 127...) and issue ppp again.  Then it works.  This
happens all the time.



 Sun, 24 Jul 2005 06:25:34 GMT   
 ppp.linkup not executed

Hmm, doesn't look executable to me. chmod 744. But then, I may be wrong for
ppp.

EJ
--
Remove the obvious part (including the dot) for my email address



 Sun, 24 Jul 2005 06:42:30 GMT   
 ppp.linkup not executed

Right! That was the problem! Now it is running fiiiine.

Hmm... I use PPPOE (DSL) connection. Would you please post your routing
information before and after the first and second dial?

thank you!
reiner



 Wed, 27 Jul 2005 06:16:44 GMT   
 ppp.linkup not executed
On Fri, 07 Feb 2003 23:16:44 +0100, Reiner Griess <mynewn...@gmx.net>
said the following:

Glad to help.

I managed to get it working by making a modification to my dial
script.  My main problem now is trying to figure out why my pc card
(i'm on a laptop) is performing so badly.  See my post "trouble with
cardbus".



 Wed, 27 Jul 2005 09:34:20 GMT   
 
   [ 5 post ] 

Similar Threads

1. ppp.linkup file does not run command

2. problem using ppp with ppp.linkup

3. Question about /etc/ppp/ppp.linkup

4. Automatically ftp'ing a file using ppp.linkup

5. running scripts with ppp.linkup

6. using hostname in ppp.linkup ?

7. Running Script from ppp.linkup

8. pptp and ppp.linkup

9. Ip-updater in ppp.linkup?!

10. pppd not executing /etc/ppp/ip-up


 
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by ST Software