It is currently Thu, 20 Jan 2022 03:55:13 GMT



 
Author Message
 "locate" doesn't work
Recently, I attempted to locate a file on my RH 5.2 box and received the
following message:

[root@mail cron.daily]# locate man
locate: /usr/local/var/locatedb: No such file or directory

I ran updatedb.cron and it completed successfully, but still I receive the
above message.  Look familiar?

Russ



 Mon, 28 Jan 2002 03:00:00 GMT   
 "locate" doesn't work
"Russell S. DiPesa" <russell.dip...@fintec.net> writes:

Well, is there a /usr/local/var/locatedb?  If so, there shouldn't be.
The default location of locatedb is /var/lib -- /usr/local/var makes
no sense and looks like you made a typo in your script.
-ckm



 Mon, 28 Jan 2002 03:00:00 GMT   
 "locate" doesn't work
In article <7ovglc$if...@ffx2nh3.news.uu.net>,
Russell S. DiPesa <russell.dip...@fintec.net> wrote:

never seen that before.  a solution would be to use the generic 'find'
command instead of locate.  it's much more versatile.  shouldn't locatedb
be in lie /var/lib/ or something?

possibly there's an appropriate config file to hack.
--
Coy Hile
h...@cse.psu.edu
"Theirs not to reason why; theirs but to do...."
Tennyson, "Charge of the Light Brigade"



 Mon, 28 Jan 2002 03:00:00 GMT   
 "locate" doesn't work

Why don't you try

# updatedb --outputfile=/usr/local/var/locatedb

and see what happens when you type locate "something"
next.

Ferdinand



 Tue, 29 Jan 2002 03:00:00 GMT   
 "locate" doesn't work
In article <7ovglc$if...@ffx2nh3.news.uu.net>,
Russell S. DiPesa <russell.dip...@fintec.net> wrote:

No, it loks like a mixed version where either locate or updatedb is wrong
version.

run:

rpm -V findutils

Villy



 Tue, 29 Jan 2002 03:00:00 GMT   
 "locate" doesn't work
It is not my script.  It come with RH5.2.  It should be run every day by the
system, since it is in cron.daily.  Aynway, there is a /var/lib/locatedb and
it has a size of 0 bytes.

news:m3btccv94j.fsf@loafer.worldhq.org...



 Tue, 29 Jan 2002 03:00:00 GMT   
 "locate" doesn't work
Tried it -- same result.  I ma not sure why locatedb disappeared in the
first place.  "locate" worked for awhile.

news:7p0ikq$qrp$1@pharmnl.ohout.pharmapartners.nl...



 Tue, 29 Jan 2002 03:00:00 GMT   
 "locate" doesn't work
It gives me this error:

/usr/bin/updatedb: /usr/local/var/locatedb.n: No such file or directory

Ferdinand V. Mendoza <budme...@hotmail.com> wrote in message
news:37B3AC93.47EE70F3@hotmail.com...



 Tue, 29 Jan 2002 03:00:00 GMT   
 "locate" doesn't work
"Russell S. DiPesa" <russell.dip...@fintec.net> writes:

It doesn't matter whose script it is, if it produces this error (which
you said it did) then it is broken:
         [root@mail cron.daily]# locate man
         locate: /usr/local/var/locatedb: No such file or directory

Either set $LOCATE_PATH to /usr/local/var/locatedb, use the -d option
with locate, or run updatedb with the --output option.
-ckm



 Tue, 29 Jan 2002 03:00:00 GMT   
 
   [ 9 post ] 

Similar Threads

1. append ="128M" doesn't work

2. "make" doesn't work

3. INN on Linux, "Transfer permission denied", FAQ answer doesn't work

4. "newkey" doesn't work

5. HELP: "volcheck" doesn't work

6. "w" doesn't work

7. "mail" doesn't work


 
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by ST Software