It is currently Sat, 24 Oct 2020 17:40:46 GMT



 
Author Message
 apic-io irq transform problem........
Hi all,

Sorry to post this out of nowhere - but i'm stumped.

I'm trying to attach a pci scsi interface (tekram  with the symbios/ncr
chipset 53c1010)

here's the thing:

the irq (bios and bus) has been set to 11 for this card in the pc bios.

lspci -vv -b reports this correctly (irq 11).
lspci -vv reports irq 20

but, and here's the confusing part. In dmesg: pci->apic reports that its
transforming irq 12 to irq 20. Not irq 11 as i would expect.

So in short has anyone come across apic transforming a hardware
interrupt line incorrectly and is there anyway of stopping it.

cheers,

steve



 Wed, 29 Jun 2005 13:16:42 GMT   
 apic-io irq transform problem........
I don't know if this is relevant or not, but I had a lot of trouble with a
laptop routing irq's incorrectly. I finally cured it by applying a recent ACPI
patch to the kernel (acpi takes over routing from the bios).

However, beware, 'coz applying the same patch to my desktop machine causes it
to shutdown before it has finished booting! So make sure you keep your old
kernel available if you try this route!

--
Pete
chri...@attglobal.net



 Wed, 29 Jun 2005 17:21:06 GMT   
 
   [ 2 post ] 

Similar Threads

1. IO-APIC says: unexpected IO-APIC was found

2. i810 I/O APIC (was Sticky IO-APIC problem)

3. IO-APIC Stop IRQ Sharing!

4. x86 IO-APIC and IRQ questions

5. Debian (Woody) IO-APIC problem?

6. sis735 io-apic ide1 problem

7. CUV4X-D, io-apic problem (VIA chipset)

8. Problem with 2.4.21-pre5 &kt-400&IO-APIC

9. IO APIC + ACPI Problems.

10. interrupt/IO-APIC problems...


 
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by ST Software