It is currently Sat, 24 Oct 2020 17:07:22 GMT



 
Author Message
 apic error & NMI error 30
Hi All,

    I am running Red Hat 7.1 on a MS-6120 motherboard
with dual PIII-600's and 128 Meg ECC ram.    My motherboard
does not like APIC much, so I put the following into my
lilo.conf:  Append=noapic

    As a test, I looked at my /var/log/messages to see if
it took and see the following:
            Kernel command line: auto BOOT_IMAGE=linux ro
            root=802 BOOT_FILE=/boot/vmlinuz-2.4.2-2smp noapic

    So good so far, except I keep getting stuff like this in
/var/log/messages:

            APIC error on CPU1: 02(02)
            server last message repeated 14 times
            server kernel: APIC error on CPU0: 01(04)
            server kernel: APIC error on CPU1: 02(02)
            server last message repeated 7 times
            Uhhuh. NMI received for unknown reason 30.
            server kernel: APIC error on CPU0: 02(0a)
            server kernel: Dazed and confused, but trying to continue
            Jul  2 23:02:47 server kernel: Do you have a
                     strange power saving mode enabled?

    Then a few more APIC error and I freeze up.

    Does "noapic" not work in rh 7.1?  Does anyone
know how to fix this?

Many thanks,
--Tony
aew...@gbis.com

p.s. if responding, please reply to both the newsgroups and my
eMail address (nntp problems)  --Thanks

--
-------------------------
I Fish.  Therefore, I am.
-------------------------



 Mon, 22 Dec 2003 07:15:32 GMT   
 apic error & NMI error 30
have you tried disabling apic in bios?  also, try a 'generic' kernel.  2.4.6
just came out, try that maybe.


 Mon, 22 Dec 2003 11:58:10 GMT   
 apic error & NMI error 30

This'll slow your system down no end...  it's a shame to use it - my dual p3
gives a few messages on kernel boot about "unknown IO-APIC" but it never
affected the stability of the machine so i just ignored it... :)  from what
i gather the noapic should really only be used as a last resort.  if your
mobo really can't stick it, you may want to think about changing it...

I'm sure someone will correct me if i'm wrong :)

Good Luck!

Philip



 Mon, 22 Dec 2003 14:17:49 GMT   
 apic error & NMI error 30
Hi All,

    There are no APIC settings in my BIOS.

    The really annoying thing is, why do I
still get APIC errors when I have it turned off in
lilo.conf?

    I have MSI tech support looking into a BIOS cure
for the problem.

Many thanks,
--Tony
aew...@gbis.com

--
-------------------------
I Fish.  Therefore, I am.
-------------------------



 Tue, 23 Dec 2003 10:47:23 GMT   
 
   [ 4 post ] 

Similar Threads

1. 2.0.30 compile error [vmlinux] Error 139

2. APIC error on CPU0 (UP APIC kernel)

3. Strange boot-up message about NMI 21/30/31

4. Strange boot-up message about NMI 21/30/31

5. Error compile glibc-cvs with nptl-0.30

6. Kernel 2.0.30 parse error when compiling

7. Kernel 2.0.30 Linking errors

8. error - Unable to open an initial console, doslinux version 31, kernel 2.0.30 elf

9. Error compiling PPP into kernel 2.0.30

10. NOTICE: mode=0400, inum=30, fs=/news errors


 
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by ST Software