It is currently Sun, 29 Nov 2020 12:50:30 GMT



 
Author Message
 lilo help needed (dual boot, IDE + SCSI)

OK, I am having a bit of a farce with lilo, mainly getting it to boot
Windows partitions that are on disks other than hda. Maybe someone can
help!

My workstation currently has the following drives and partitions:

/dev/hdc        40Gb IDE
  /dev/hdc1        ext2 (linux /boot)
  /dev/hdc2        ext2 (linux /mp3)

/dev/sda        18Gb SCSI
  /dev/sda1        ntfs (WinNT)
  /dev/sda2        ext2 (linux /)
  /dev/sda3        linux swap

/dev/sdb        4Gb SCSI
  /dev/sdb1        ntfs (Win2000)

I am forced to boot from the MBR on hdc, as the Compaq BIOS can't be set
to boot
from SCSI if it has any IDE drives at all (doh!).

Booting into linux is no problem, but I can't boot into either windows
partition if I have the IDE drive present. (It just says "Booting WinNT
..." and then hangs). Both windows partitions boot fine if they are on
the
first SCSI disk with no IDE present but not otherwise (the NT partition
has been booted both with and without lilo; the Win2k partition has
been booted only without lilo).

My lilo.conf is below, using lilo v21.6-1. I have also tried various
combinations of 'map-drive' in the 'other' sections, but none seem to
work (I don't know enough about Windows booting to know if this is the
right thing to do anyway). If somone could tell me what incantations to
mutter at lilo (and/or the 'boot.ini' files in windows) to get the
windows partitions to boot, I would be most grateful.

Jon

lilo.conf follows:
#################################################################################

boot=/dev/hdc
map=/boot/map
install=/boot/boot.b
prompt
timeout=100
lba32
fix-table
default=l-2.4.3-jon3

image=/boot/vmlinuz-2.4.3-jon3
        label=l-2.4.3-jon3
        append = "apm=power-off"
        root=/dev/sda2
        read-only

image=/boot/vmlinuz-2.4.3-jon2
        label=l-2.4.3-jon2
        append = "apm=power-off"
        root=/dev/sda2
        read-only

image=/boot/vmlinuz-2.2.17-jon3-smp
        label=l-2.2.17-jon3
        append = "apm=power-off"
        root=/dev/sda2
        read-only

other=/dev/sda1
        label=winNT
        loader=/boot/chain.b
        table=/dev/sda

other=/dev/sdb1
        label=win2k
        loader=/boot/chain.b
        table=/dev/sdb

##########################################################################

--
Jon Wilson                                     http://www.**-**.com/
Net S.W. Ltd, Bath, UK                            Tel. (07776) 137939
   There's lots of ways to blaze a trail ... like that prehistoric
  gourmet who looked at that lobster and said "I'm gonna eat that."



 Sat, 25 Oct 2003 00:11:29 GMT   
 lilo help needed (dual boot, IDE + SCSI)

Fixed.

Followup to my lilo multiboot, multidisc farce. The following lilo.conf
works. It seems I need global 'disk' and 'bios' options, and per-image
'map-drive' options for the foreign OS's.

# (note: hda is cdrom)
# First IDE Disk, Hard Disk 0
disk=/dev/hdc
     bios=0x80
# First SCSI Disk, Hard Disk 1
disk=/dev/sda
     bios=0x81
# Second SCSI Disk, Hard Disk 2
disk=/dev/sdb
     bios=0x82

# Boot from MBR on IDE disk
boot=/dev/hdc
map=/boot/map
install=/boot/boot.b
prompt
timeout=100
lba32
fix-table
default=l-2.4.4-jon2

image=/boot/vmlinuz-2.4.4-jon1
        label=l-2.4.4-jon1
        append = "apm=power-off"
        root=/dev/sda2
        read-only

image=/boot/vmlinuz-2.4.4-jon2
        label=l-2.4.4-jon2
        append = "apm=power-off"
        root=/dev/sda2
        read-only

#[other linux kernels snipped]

other=/dev/sda1
        label=winNT
        loader=/boot/chain.b
        table=/dev/sda
        # Map Hard Disk 0 to Hard Disk 1
        map-drive=0x80
                to=0x81
        # Map Hard Disk 1 to Hard Disk 0
        map-drive=0x81
                to=0x80

other=/dev/sdb1
        label=win2k
        loader=/boot/chain.b
        table=/dev/sdb
        # Map Hard Disk 0 to Hard Disk 2
        map-drive=0x80
                to=0x82
        # Map Hard Disk 2 to Hard Disk 0
        map-drive=0x82
                to=0x80

--
Jon Wilson                                     http://www.netsw.co.uk
Net S.W. Ltd, Bath, UK                            Tel. (07776) 137939
              Hand me my nosering! Show me the mosh pit!
                     We can be happy underground!



 Mon, 27 Oct 2003 00:03:23 GMT   
 
   [ 2 post ] 

Similar Threads

1. Help needed with Lilo dual boot

2. IDE + SCSI + LILO (boot SCSI) how?

3. LILO config for dual boot: Win98 / Linux w/two IDE drives

4. Dual Boot configuration w/ LILO and 2 SCSI Disks

5. cdrom-scsi/XP-woody on hdb dual boot/lilo conundrum

6. SCSI LILO Dual Boot Question

7. Dual boot win2k on IDE and Linux on SCSI

8. IDE Linux - SCSI Windows - dual boot setup

9. dual boot/ IDE/SCSI?

10. How to setup dual boot: NT on IDE, x86 2.5 on SCSI


 
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by ST Software